Ranking Error
Resolved
Apr 23, 2023 at 10:07pm UTC
All services are back up and running.
Affected services
Updated
Apr 20, 2023 at 10:41pm UTC
Users are still reporting issues after passing an application, we are looking into it.
Affected services
Updated
Apr 20, 2023 at 9:21pm UTC
All services are back up and running.
Affected services
Updated
Apr 20, 2023 at 2:55pm UTC
Many users are experiencing errors when attempting to start an application, we are in contact with our providers to resolve the issue.
Affected services
Updated
Apr 18, 2023 at 11:11pm UTC
All services are back up and running.
Affected services
Created
Apr 15, 2023 at 12:18am UTC
Many users have reported a ranking error when passing an application. We're reviewing this currently.
Affected services