Back to overview
Downtime
Bot Errors
May 01 at 02:12pm BST
Affected services
Product Hub
Resolved
Jun 22 at 09:01pm BST
The discord bot is no longer available for linking, please visit https://packables.store/63389aeaed3f6516455a92f0 to continue to redeeming purchased products.
Affected services
Product Hub
Created
May 01 at 02:12pm BST
Many customers are reporting issues when claiming their purchased product, the place has been closed until further notice.
Affected services
Product Hub