Back to overview
Downtime
Ranking Unavailable
Aug 17 at 09:25pm BST
Affected services
Thorngate Park Store
Training Centre
Ranking Centre
Application Centre
Resolved
Aug 18 at 12:20pm BST
Services seem to have normalized for now, we will continue monitoring any changes that may affect us.
Affected services
Thorngate Park Store
Training Centre
Ranking Centre
Application Centre
Created
Aug 17 at 09:25pm BST
Many users are experiencing errors when attempting to start an application, claim a rank, or rank players at the training centre. We are working with our team to resolve the issue ASAP.
Affected services
Thorngate Park Store
Training Centre
Ranking Centre
Application Centre