Major Outage: Players Unable to Join Games (Roblox Group API Failure)
Resolved
May 5, 2026 at 1:00am UTC
The issue affecting player access to Vireon Studios experiences has now been resolved.
Roblox implemented a fix for the GroupService:GetGroupsAsync() outage at 01:49 (BST), restoring normal functionality.
Players are now able to successfully load into Freshly Shopping UK and Wingin’ It Restaurants, with group data correctly fetching during the loading process.
We will continue to monitor the situation to ensure full stability, but all systems are currently operating as expected.
Thank you for your patience during this disruption.
Affected services
Created
May 4, 2026 at 11:15pm UTC
We are currently experiencing a major service disruption affecting all Vireon Studios experiences, including Freshly Shopping UK and Wingin’ It Restaurants, due to an external issue with Roblox.
The GroupService:GetGroupsAsync() API is currently returning an HTTP 401 error, preventing us from retrieving player group data during the loading process.
Our loading system requires group data to assign correct spawn locations, provide appropriate tools and apply role-based permissions.
As a result, players are currently unable to successfully load into our games.
This issue is not isolated to Vireon Studios and is impacting all Roblox experiences that rely on this API.
At this time, there is no workaround available, as our systems depend on group rank data to function correctly.
We are actively monitoring the situation and awaiting an update from Roblox. Further information can be found on the official developer thread here:
https://devforum.roblox.com/t/groupservicegetgroupsasync-returning-http-401-response/4618892
We will provide updates as soon as more information becomes available.
Affected services